Sage 50 Critical Security Updates Expire September 2023!

Below is the message Sage is sending to customers regarding this Expiration.   Please read and contact Baytek to discuss options for obtaining the latest version of Sage 50 – US Edition.  ACT NOW to avoid losing access to Sage 50!

Dear Valued Customer:

 We are writing to remind you about some critical security updates that impact versions 2020.1 and earlier of Sage 50.  On September 30, 2023, you will be unable to reinstall or reactivate the following older versions of Sage 50: version 2020.1 and all prior versions.  If you do not act prior to September 30, 2023, you will lose access to Sage 50. 

 What is changing? 

Transport Layer Security (TLS) v1.0 and 1.1 is a third-party component that is used in versions 2020.1 and earlier of Sage 50 that we no longer support due to security-related issues. Newer versions of Sage 50 no longer utilize TLS v1.0 and v1.1.

 What does this mean for me?

If you are using an older version of Sage 50 that is impacted by this change, the next time the software attempts a license validation check after September 30, 2023, an error will appear, and you will be prevented from accessing the software.  

 What do I need to do?

To avoid disruption to your business, we strongly recommend you upgrade to the latest supported version (2023.0) of Sage 50. In doing so, you will receive critical security updates relating to this protocol that better help protect your data.

If you are not on an active plan, you will have the following options: 

•            Option 1: Purchase a subscription to the latest version of Sage 50, which includes auto renewing subscription fees. 

•            Option 2: If you do not intend to upgrade, you must export your data before your access to Sage 50 expires on September 30, 2023. 

Please contact Baytek  to discuss options for obtaining the latest version of Sage 50—U.S. Edition at unadvertised pricing.    800.487.3224 or email us sales@baytek.com  

Leave a Comment

Your email address will not be published. Required fields are marked *